#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{2}\/\d{2}\/\d{4}"
Local $sString = "AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"AAAAAAAA em: 20/04/2017" & @CRLF & _
"" & @CRLF & _
"AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"AAAAAAA em: 20/04/2017" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"AAAAAA em: 21/06/2016" & @CRLF & _
"" & @CRLF & _
"AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"AAAAAA em: 20/04/2017" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"AAAAAA em: 20/04/2017"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")