import Foundation
let pattern = #"\d{2}\/\d{2}\/\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAA
AAAAAAAA em: 20/04/2017
AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAA
AAAAAAA em: 20/04/2017
AAAAAAAAAAAAAAAAAAAAAAAA
AAAAAA em: 21/06/2016
AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAA
AAAAAA em: 20/04/2017
AAAAAAAAAA AAAAAAAAAAA - AAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAA
AAAAAA em: 20/04/2017
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)