const regex = /^(?=(?:[0-9_]*[a-z]){3})[a-z0-9_]{5,}$/smg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:[0-9_]*[a-z]){3})[a-z0-9_]{5,}$', 'smg')
const str = `john_doe
johndoe
John Doe
john.doe
john
j2e2p2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}