use strict;
my $str = 'john_doe
johndoe
John Doe
john.doe
john
j2e2p2
';
my $regex = qr/^(?=(?:[0-9_]*[a-z]){3})[a-z0-9_]{5,}$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}