const regex = /\b(?=.*\d)[a-zA-Z\d]{9}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=.*\\d)[a-zA-Z\\d]{9}\\b', 'g')
const str = `10/01/2016 1,060X 8.999%!!! 1.33 0.666 928888XE0
ABCDEBATX ..... 6 ,,00,001% 20///^^ addcA7 7777a 123456789 djaoij8888888 0.000001 12@
FAR687465 B22222222 __ djj^66 20/20/20/20 1:
fil476 .00 20/.. BUT AAAAAAAAA k98776 000.0001 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}