$re = '/\b(?=.*\d)[a-zA-Z\d]{9}\b/';
$str = '10/01/2016 1,060X 8.999%!!! 1.33 0.666 928888XE0
ABCDEBATX ..... 6 ,,00,001% 20///^^ addcA7 7777a 123456789 djaoij8888888 0.000001 12@
FAR687465 B22222222 __ djj^66 20/20/20/20 1:
fil476 .00 20/.. BUT AAAAAAAAA k98776 000.0001 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);