const regex = /(?<zip>\d{4,})(?=\s\w+|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<zip>\\d{4,})(?=\\s\\w+|$)', 'g')
const str = `41 Rue Larrepunte 64200 Biarritz
41 Rue Larrepunte Biarritz 64200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}