import re
regex = re.compile(r"(?<zip>\d{4,})(?=\s\w+|$)")
test_str = ("41 Rue Larrepunte 64200 Biarritz\n"
"41 Rue Larrepunte Biarritz 64200")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")