#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^N\s+(\d+)$"
Local $sString = "R.U.T .: 99.999.999-9" & @CRLF & _
"COMPANY" & @CRLF & _
"ELECTRONIC TICKET" & @CRLF & _
"Committed to you" & @CRLF & _
"N" & @CRLF & _
"54280631" & @CRLF & _
"COMPANY S.A. SALE" & @CRLF & _
"RUT: 99.999.999-9 Directory 111, City" & @CRLF & _
"" & @CRLF & _
"R.U.T .: 99.999.999-9" & @CRLF & _
"COMPANY" & @CRLF & _
"ELECTRONIC TICKET" & @CRLF & _
"Committed to you" & @CRLF & _
"N 54280631" & @CRLF & _
"COMPANY S.A. SALE" & @CRLF & _
"RUT: 99.999.999-9 Directory 111, City"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")