import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^N\\s+(\\d+)$";
final String string = "R.U.T .: 99.999.999-9\n"
+ "COMPANY\n"
+ "ELECTRONIC TICKET\n"
+ "Committed to you\n"
+ "N\n"
+ "54280631\n"
+ "COMPANY S.A. SALE\n"
+ "RUT: 99.999.999-9 Directory 111, City\n\n"
+ "R.U.T .: 99.999.999-9\n"
+ "COMPANY\n"
+ "ELECTRONIC TICKET\n"
+ "Committed to you\n"
+ "N 54280631\n"
+ "COMPANY S.A. SALE\n"
+ "RUT: 99.999.999-9 Directory 111, City";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}