const regex = /(?i)(?<="SSIDName":")[^"]+(?=")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<="SSIDName":")[^"]+(?=")', 'gm')
const str = `{"SSIDIndex":2,"SSIDName":"BBKH2-0272-2" ,"Band":"2.4GHz","Status":"RadioIndex":1,"SSIDIndex":3,"SSIDName":"BBH@5","ssidname":"1234" }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}