re = /(?i)(?<="SSIDName":")[^"]+(?=")/m
str = '{"SSIDIndex":2,"SSIDName":"BBKH2-0272-2" ,"Band":"2.4GHz","Status":"RadioIndex":1,"SSIDIndex":3,"SSIDName":"BBH@5","ssidname":"1234" }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end