using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[U|V]GRD:10 m above";
string input = @":REFD:4000 m above ground:12 hour fcst
:REFD:1000 m above ground:12 hour fcst
:TMP:2 m above ground:12 hour fcst
:SPFH:2 m above ground:12 hour fcst
:DPT:2 m above ground:12 hour fcst
:RH:2 m above ground:12 hour fcst
:APTMP:2 m above ground:12 hour fcst
:TMAX:2 m above ground:6-12 hour max fcst
:TMIN:2 m above ground:6-12 hour min fcst
:UGRD:10 m above ground:12 hour fcst
:VGRD:10 m above ground:12 hour fcst
:HLCY:3000-0 m above ground:12 hour fcst
:USTM:6000-0 m above ground:12 hour fcst
:VSTM:6000-0 m above ground:12 hour fcst
:UGRD:20 m above ground:12 hour fcst
:VGRD:20 m above ground:12 hour fcst
:UGRD:30 m above ground:12 hour fcst
:VGRD:30 m above ground:12 hour fcst
:UGRD:40 m above ground:12 hour fcst
:VGRD:40 m above ground:12 hour fcst
:UGRD:50 m above ground:12 hour fcst
:VGRD:50 m above ground:12 hour fcst
:TMP:80 m above ground:12 hour fcst
:SPFH:80 m above ground:12 hour fcst
:PRES:80 m above ground:12 hour fcst
:UGRD:80 m above ground:12 hour fcst
:VGRD:80 m above ground:12 hour fcst
:TMP:100 m above ground:12 hour fcst
:UGRD:100 m above ground:12 hour fcst
:VGRD:100 m above ground:12 hour fcst
:TMP:30-0 mb above ground:12 hour fcst
:RH:30-0 mb above ground:12 hour fcst
:SPFH:30-0 mb above ground:12 hour fcst
:UGRD:30-0 mb above ground:12 hour fcst
:VGRD:30-0 mb above ground:12 hour fcst
:CAPE:180-0 mb above ground:12 hour fcst
:CIN:180-0 mb above ground:12 hour fcst
:CAPE:90-0 mb above ground:12 hour fcst
:CIN:90-0 mb above ground:12 hour fcst
:CAPE:255-0 mb above ground:12 hour fcst
:CIN:255-0 mb above ground:12 hour fcst
:PLPL:255-0 mb above ground:12 hour fcst";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}