import re
regex = re.compile(r":[U|V]GRD:10 m above", flags=re.MULTILINE)
test_str = (":REFD:4000 m above ground:12 hour fcst\n"
":REFD:1000 m above ground:12 hour fcst\n"
":TMP:2 m above ground:12 hour fcst\n"
":SPFH:2 m above ground:12 hour fcst\n"
":DPT:2 m above ground:12 hour fcst\n"
":RH:2 m above ground:12 hour fcst\n"
":APTMP:2 m above ground:12 hour fcst\n"
":TMAX:2 m above ground:6-12 hour max fcst\n"
":TMIN:2 m above ground:6-12 hour min fcst\n"
":UGRD:10 m above ground:12 hour fcst\n"
":VGRD:10 m above ground:12 hour fcst\n"
":HLCY:3000-0 m above ground:12 hour fcst\n"
":USTM:6000-0 m above ground:12 hour fcst\n"
":VSTM:6000-0 m above ground:12 hour fcst\n"
":UGRD:20 m above ground:12 hour fcst\n"
":VGRD:20 m above ground:12 hour fcst\n"
":UGRD:30 m above ground:12 hour fcst\n"
":VGRD:30 m above ground:12 hour fcst\n"
":UGRD:40 m above ground:12 hour fcst\n"
":VGRD:40 m above ground:12 hour fcst\n"
":UGRD:50 m above ground:12 hour fcst\n"
":VGRD:50 m above ground:12 hour fcst\n"
":TMP:80 m above ground:12 hour fcst\n"
":SPFH:80 m above ground:12 hour fcst\n"
":PRES:80 m above ground:12 hour fcst\n"
":UGRD:80 m above ground:12 hour fcst\n"
":VGRD:80 m above ground:12 hour fcst\n"
":TMP:100 m above ground:12 hour fcst\n"
":UGRD:100 m above ground:12 hour fcst\n"
":VGRD:100 m above ground:12 hour fcst\n"
":TMP:30-0 mb above ground:12 hour fcst\n"
":RH:30-0 mb above ground:12 hour fcst\n"
":SPFH:30-0 mb above ground:12 hour fcst\n"
":UGRD:30-0 mb above ground:12 hour fcst\n"
":VGRD:30-0 mb above ground:12 hour fcst\n"
":CAPE:180-0 mb above ground:12 hour fcst\n"
":CIN:180-0 mb above ground:12 hour fcst\n"
":CAPE:90-0 mb above ground:12 hour fcst\n"
":CIN:90-0 mb above ground:12 hour fcst\n"
":CAPE:255-0 mb above ground:12 hour fcst\n"
":CIN:255-0 mb above ground:12 hour fcst\n"
":PLPL:255-0 mb above ground:12 hour fcst")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")