const regex = /@\[[a-z0-9-]+\]\(([\w-]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@\\[[a-z0-9-]+\\]\\(([\\w-]+)\\)', 'gm')
const str = `@[a12-3asd-32](john)
@[b12-32d1-23](martha)
@[c12-12d1-13](john-user-1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}