import re
regex = re.compile(r"@\[[a-z0-9-]+\]\(([\w-]+)\)", flags=re.MULTILINE)
test_str = ("@[a12-3asd-32](john) \n"
"@[b12-32d1-23](martha)\n"
"@[c12-12d1-13](john-user-1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")