use strict;
my $str = '/akcija
/akcija/
/akcija/12
/akcija/12/
/akcija/1234
/akcija/1234/
/akcija/qweq
/akcija/qweq/
/akcija/123456
/akcija/123456/
/akcija/qweqwe
/akcija/qweqwe/
/akcija/1234/ffff
/akcija/1234/ffff/';
my $regex = qr/(?'w'\/akcija(?'q'\/)([A-Za-z0-9-]+)(\k'q'))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}