$re = '/(?\'w\'\/akcija(?\'q\'\/)([A-Za-z0-9-]+)(\k\'q\'))/m';
$str = '/akcija
/akcija/
/akcija/12
/akcija/12/
/akcija/1234
/akcija/1234/
/akcija/qweq
/akcija/qweq/
/akcija/123456
/akcija/123456/
/akcija/qweqwe
/akcija/qweqwe/
/akcija/1234/ffff
/akcija/1234/ffff/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);