$re = '/[A-Z]{2,}/m';
$str = 'lower case string
lower with UPPER case string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);