$re = '/(?:(?P<inverted>\!) )?(?P<names>\-{1,2}\S+)($| (?P<values>.+(?=(?: [\!|\-])|$)))/U';
$str = '-a val1 ! -b val2 --custom "string with crazy -a --test stuff inside" --param-with-dash val1 val2 -c ! -d ! --test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);