use strict;
my $str = 'var components = \'string_1 string_2 string_3\';
"string_1"
\'string_1\'
"string_1 string2"
\'string_1 string2\'
"string_1 string2 string3"
Also it needs not to match
$string_1
#string_1$
string_1
//string_1
/*string_1
\\string_1
!string_1
';
my $regex = qr/(['"])(?=[\w ]+\1)\K\w+|\G \K\w+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}