$re = '/([\'"])(?=[\w ]+\1)\K\w+|\G \K\w+/';
$str = 'var components = \'string_1 string_2 string_3\';
"string_1"
\'string_1\'
"string_1 string2"
\'string_1 string2\'
"string_1 string2 string3"
Also it needs not to match
$string_1
#string_1$
string_1
//string_1
/*string_1
\\string_1
!string_1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);