use strict;
my $str = 'Rue Bois des Fosses 394
Rue Bois, des Fosses 393
Rue Bois. des Fosses 3
Rue Bois des Fosses 0
Rue de la Briqueterie 134 something extra
Rue Haute
Ramselsesteenweg 1
Ramselsesteenweg 188353454
Ramselsesteenweg188a
Ramselsesteenweg 091
Ramselsesteenweg 091a
Ramselsesteenweg 0
Ramselsesteenweg
188
0
12b
123 Ramselsesteenweg
123 Ramselsesteenweg 9';
my $regex = qr/[0-9a-zA-Z:,. ]+[ ](?!0+$)\d[\w ]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}