$re = '/[0-9a-zA-Z:,. ]+[ ](?!0+$)\d[\w ]*/m';
$str = 'Rue Bois des Fosses 394
Rue Bois, des Fosses 393
Rue Bois. des Fosses 3
Rue Bois des Fosses 0
Rue de la Briqueterie 134 something extra
Rue Haute
Ramselsesteenweg 1
Ramselsesteenweg 188353454
Ramselsesteenweg188a
Ramselsesteenweg 091
Ramselsesteenweg 091a
Ramselsesteenweg 0
Ramselsesteenweg
188
0
12b
123 Ramselsesteenweg
123 Ramselsesteenweg 9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);