package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^@,;\s]+@[^@,;\s]+)|(?:$|\s*[,;])(?:\s*)(.*?)<([^@,;\s]+@[^@,;\s]+)>`)
var str = `name@domain.com,Sixpack, Joe 1 <name@domain.com>, Sixpack, Joe 2 <name@domain.com> ;Sixpack, Joe, 3<name@domain.com> , nameFoo@domain.com,nameBar@domain.com;nameBaz@domain.com;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}