package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(19|20)([0-9]{2})-([0-9]{2}|0[0-9]{1})-([0-9]{2}|0[0-9]{1})$`)
var str = `2019-04-04`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}