re = /^(19|20)([0-9]{2})-([0-9]{2}|0[0-9]{1})-([0-9]{2}|0[0-9]{1})$/mi
str = '2019-04-04'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end