// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^[-+]?(\d+[,.]|\d*[.,]?\d+)(e[-+]?\d+)?$").unwrap();
let string = "3.14159
";
let substitution = "-";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}