$re = '/\/(\wp-login|wp-admin).*\.php$/m';
$str = '/wp-login.php
/wp-admin/index.php
/wp-admin/update-core.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);