re = /\/(\wp-login|wp-admin).*\.php$/m
str = '/wp-login.php
/wp-admin/index.php
/wp-admin/update-core.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end