#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\+|\+\s|\d{1}\s?|\()(\d\)?\s?[-\.\s\(]??){8,}\d{1}|\d{3}[-\.\s]??\d{3}[-\.\s]??\d{4}|\(\d{3}\)\s*\d{3}[-\.\s]??\d{4}|\d{3}[-\.\s]??\d{4})"
Local $sString = " +61 2 8249 5000" & @CRLF & _
" +61 2 6122 5100" & @CRLF & _
" +61 2-9407 5247" & @CRLF & _
" +65-8233-6124" & @CRLF & _
" +61 412 364 923" & @CRLF & _
" 1300 890 902" & @CRLF & _
" 0435 569 072" & @CRLF & _
" 8801911384785" & @CRLF & _
" 0086-010-58732690" & @CRLF & _
" + 852 2118 3893" & @CRLF & _
" (852) 2513 3168" & @CRLF & _
" (852) 2865-9898" & @CRLF & _
" +91-9552503220" & @CRLF & _
" +914042024714" & @CRLF & _
" +919948298078" & @CRLF & _
" +91 22 25094755" & @CRLF & _
" 0124 4742300" & @CRLF & _
" +1 (972)273 0738" & @CRLF & _
" 08111 90 1859" & @CRLF & _
" +62-21-5201214" & @CRLF & _
" +62 21 2995 1641" & @CRLF & _
" 603-4270 2309" & @CRLF & _
" +603 7724 1199" & @CRLF & _
" +603-77108288" & @CRLF & _
" +632 8937377" & @CRLF & _
" (65) 6723 6888" & @CRLF & _
" +6596233196" & @CRLF & _
" +656379 2681" & @CRLF & _
" +65 6737 0324" & @CRLF & _
" 82-70-7791-7100" & @CRLF & _
" +82 17 238 1226" & @CRLF & _
" 82-31-478-4506" & @CRLF & _
" +822-6309-6366" & @CRLF & _
" (000)000-0000 " & @CRLF & _
" (000)000 0000 " & @CRLF & _
" (000)000.0000" & @CRLF & _
" (000) 000-0000" & @CRLF & _
" (000) 000 0000 " & @CRLF & _
" (000) 000.0000 " & @CRLF & _
" 0000000000" & @CRLF & _
" (000)0000000" & @CRLF & _
"" & @CRLF & _
" (000)000-0000 " & @CRLF & _
" (000)000 0000 " & @CRLF & _
" (000)000.0000" & @CRLF & _
" (000) 000-0000" & @CRLF & _
" (000) 000 0000 " & @CRLF & _
" (000) 000.0000 " & @CRLF & _
" 000-0000 " & @CRLF & _
" 000 0000 " & @CRLF & _
" 000.0000 " & @CRLF & _
" 0000000 " & @CRLF & _
" 0000000000 " & @CRLF & _
" (000)0000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")