# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\+|\+\s|\d{1}\s?|\()(\d\)?\s?[-\.\s\(]??){8,}\d{1}|\d{3}[-\.\s]??\d{3}[-\.\s]??\d{4}|\(\d{3}\)\s*\d{3}[-\.\s]??\d{4}|\d{3}[-\.\s]??\d{4})"
test_str = (" +61 2 8249 5000\n"
" +61 2 6122 5100\n"
" +61 2-9407 5247\n"
" +65-8233-6124\n"
" +61 412 364 923\n"
" 1300 890 902\n"
" 0435 569 072\n"
" 8801911384785\n"
" 0086-010-58732690\n"
" + 852 2118 3893\n"
" (852) 2513 3168\n"
" (852) 2865-9898\n"
" +91-9552503220\n"
" +914042024714\n"
" +919948298078\n"
" +91 22 25094755\n"
" 0124 4742300\n"
" +1 (972)273 0738\n"
" 08111 90 1859\n"
" +62-21-5201214\n"
" +62 21 2995 1641\n"
" 603-4270 2309\n"
" +603 7724 1199\n"
" +603-77108288\n"
" +632 8937377\n"
" (65) 6723 6888\n"
" +6596233196\n"
" +656379 2681\n"
" +65 6737 0324\n"
" 82-70-7791-7100\n"
" +82 17 238 1226\n"
" 82-31-478-4506\n"
" +822-6309-6366\n"
" (000)000-0000 \n"
" (000)000 0000 \n"
" (000)000.0000\n"
" (000) 000-0000\n"
" (000) 000 0000 \n"
" (000) 000.0000 \n"
" 0000000000\n"
" (000)0000000\n\n"
" (000)000-0000 \n"
" (000)000 0000 \n"
" (000)000.0000\n"
" (000) 000-0000\n"
" (000) 000 0000 \n"
" (000) 000.0000 \n"
" 000-0000 \n"
" 000 0000 \n"
" 000.0000 \n"
" 0000000 \n"
" 0000000000 \n"
" (000)0000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.