const regex = /(?i)<label id="\{[\d\w-]+}">([a-z ]+)<\/label>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<label id="\\{[\\d\\w-]+}">([a-z ]+)<\\\/label>', 'gm')
const str = `<p>
<title>Contact Us</title>
</p>
<table dropzone="copy">
<tbody>
<tr>
<td class="label" style="cursor: default;">Full Name</td>
<td style=
"cursor: default;">[<label id="{0a4a7240-9606-416a-bf7b-ef11a47cca8e}">First name</label>] [<label id="{94263497-683b-46f9-ba0f-69f4c2736598}">Last name</label>]</td>
</tr>
<tr>
<td class="label" style="cursor: d
efault;">Telephone</td>
<td style="cursor: default;">[<label id="{ce68e02e-e9fd-40ee-9375-ee1b05972e9b}">Phone</label>]</td>
</tr>
<tr>
<td class="label" style="cursor: default;">Email</td>
<td style="cursor: default;">[<label id="{411b580e-f7e9-4dd2-a70d-947385360cd0}">Email</label>]</td>
</tr>
<tr>
<td class="label" style="cursor: default;">Message</td>
<td style="cursor: default;">[
<label id="{13e2ff23-135c-4c6d-beb4-2960a533cb98}">Your Message</label>]</td>
</tr>
<tr>
<td class="label" style="cursor: default;">Company</td>
<td style="cursor: default;">[<label id="{c3f22c3a-8fc1
-48a4-8d6a-fe346024ca2b}">Company</label>]</td>
</tr>
</tbody>
</table>
<p> </p>
<p> </p>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);