# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)<label id=\"\{[\d\w-]+}\">([a-z ]+)<\/label>"
test_str = ("<p>\n"
"<title>Contact Us</title>\n"
"</p>\n"
"<table dropzone=\"copy\">\n"
" <tbody>\n"
" <tr>\n"
" <td class=\"label\" style=\"cursor: default;\">Full Name</td>\n"
" <td style=\n"
"\"cursor: default;\">[<label id=\"{0a4a7240-9606-416a-bf7b-ef11a47cca8e}\">First name</label>] [<label id=\"{94263497-683b-46f9-ba0f-69f4c2736598}\">Last name</label>]</td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"label\" style=\"cursor: d\n"
"efault;\">Telephone</td>\n"
" <td style=\"cursor: default;\">[<label id=\"{ce68e02e-e9fd-40ee-9375-ee1b05972e9b}\">Phone</label>]</td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"label\" style=\"cursor: default;\">Email</td>\n"
" <td style=\"cursor: default;\">[<label id=\"{411b580e-f7e9-4dd2-a70d-947385360cd0}\">Email</label>]</td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"label\" style=\"cursor: default;\">Message</td>\n"
" <td style=\"cursor: default;\">[\n"
"<label id=\"{13e2ff23-135c-4c6d-beb4-2960a533cb98}\">Your Message</label>]</td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"label\" style=\"cursor: default;\">Company</td>\n"
" <td style=\"cursor: default;\">[<label id=\"{c3f22c3a-8fc1\n"
"-48a4-8d6a-fe346024ca2b}\">Company</label>]</td>\n"
" </tr>\n"
" </tbody>\n"
"</table>\n"
"<p> </p>\n"
"<p> </p>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.