import re
regex = re.compile(r"\.[A-Za-z]+\.\d+", flags=re.MULTILINE)
test_str = ("aaa/prt001.prt.1\n"
"aaa/prt001.prt.2\n"
"aaa/prt001.prt.3\n"
"aaa/prt001.prt.4\n"
"aaa/prt001.prt.5\n"
"aaa/prt001.prt.10\n"
"aaa/prt001.asm.1\n"
"aaa/prt001.asm.2\n"
"aaa/prt001.asm.3\n"
"aaa/prt001.txt.10\n"
"aaa/prt001.txt.20\n"
"aaa/prt001.txt.30\n"
"bbb/prt001.prt\n"
"bb/prt.001.prt\n"
"bb/prt.001.prt.1\n"
"bb/prt.001.1\n"
"bb/prt.ppp.prt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")