package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)operator\D+(\d+)`)
var str = `I have following string dfed operator 11 - 145. I am trying to match string operator 11 and inside this matched string, i am trying to match string 11. Currently I successfully matched operator 11 with regex ((O|o)perator(i|I)?\s*)\d+(?=\s*(-|_)\s*\d+). As I am in javascript, I can not use lookbehinds.
Is my approach correct? Is there any way to accomplish this in regex? How can i match string 11 inside previously matched string operator 11?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}