use strict;
my $str = 'I have following string dfed operator 11 - 145. I am trying to match string operator 11 and inside this matched string, i am trying to match string 11. Currently I successfully matched operator 11 with regex ((O|o)perator(i|I)?\\s*)\\d+(?=\\s*(-|_)\\s*\\d+). As I am in javascript, I can not use lookbehinds.
Is my approach correct? Is there any way to accomplish this in regex? How can i match string 11 inside previously matched string operator 11?';
my $regex = qr/operator\D+(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}