import re
regex = re.compile(r"\S+\[v=\"(customDate)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns_period|mpt_statistics_period\/\w+)\/(\w+)\/(\w+)")
test_str = ("root/1-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"asOfDate\":\"2016-12-31\",\"startDate\":\"2016-05-31\"}\"]/data/share_classes/array[1]/returns_period/net/cumulative\n\n\n"
"root/2-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/returns_period/net/cumulative\n\n\n"
"root/2-825-ReturnAndStatsCompositeAPI[v=\"customDate-return\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown\n\n"
"root/3-825-ReturnAndStatsCompositeAPI[v=\"customDate-index\",g=\"customDate\",p=\"{\"column\":\"column1\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2016-05-31\"}\"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative\n\n"
"root/6-825-ReturnAndStatsCompositeAPI[v=\"customDate-benchmark\",g=\"customDate\",p=\"{\"column\":\"column2\",\"asOfDate\":\"2016-05-31\",\"startDate\":\"2016-01-31\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")