import Foundation
let pattern = #"\S+\[v=\"(customDate)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+\/(returns_period|mpt_statistics_period\/\w+)\/(\w+)\/(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
root/1-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/returns_period/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="customDate-return",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/mpt_statistics_period/absolute/net/maximum_drawdown
root/3-825-ReturnAndStatsCompositeAPI[v="customDate-index",g="customDate",p="{"column":"column1","asOfDate":"2016-12-31","startDate":"2016-05-31"}"]/data/share_classes/array[0]/indices/indices_breakdown/array[0]/returns_period/net/cumulative
root/6-825-ReturnAndStatsCompositeAPI[v="customDate-benchmark",g="customDate",p="{"column":"column2","asOfDate":"2016-05-31","startDate":"2016-01-31"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_period/relative/net/bear_alpha
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)