import re
regex = re.compile(r"^\s*Processo\s*\d{7}\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\,", flags=re.MULTILINE)
test_str = ("PROCESSO :1000069-51.2019.8.26.0486\n"
"Processo 0000508-21.2015.8.26.0486\n"
"Processo 0010464-93.2018.8.26.0506/02\n"
"Processo 0022276-35.2018.8.26.0506/562\n"
"Nº 0000002-25.2019.8.26.9048\n"
"540.423 -\n"
"1.125.553 -\n"
"NPE 950.128\n"
"PEC 910.494 \n"
"NPE 1.177.941\n"
"EXPEDIENTE AVULSO - NPE 1.089.733\n"
"EXECUÇÃO: 699.764\n"
"EXECUÇÃO: 1.101.909\n"
"CPPJ 12/2013 E 64/2013 \n"
"1. EXECUÇÃO Nº 629.142\n"
"2. EXECUÇÃO Nº 1.013.657\n"
"PROTOCOLO Nº 543 FSBL 1800017858-9\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")