package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(VP\h+\(V\w*\h+\w*\)`)
var str = `(ROOT (S (NP (PRP It)) (VP (VBZ is) (RB not) (VP (VBN transmitted) (PP (IN from) (: :) (S (VP (VBG giving) (NP (NP (NP (NP (NML (NN blood)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}