re = /\(VP\h+\(V\w*\h+\w*\)/m
str = '(ROOT (S (NP (PRP It)) (VP (VBZ is) (RB not) (VP (VBN transmitted) (PP (IN from) (: :) (S (VP (VBG giving) (NP (NP (NP (NP (NML (NN blood)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end