using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\\\(.|\n)*?\\\\)";
string input = @"\\ a multiline
comment \\
print (a)
\\inheritance and polymorphism\\;print (""ab"");\\b\\;print(""end"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}