$re = '/(\\\\\\\\(.|\n)*?\\\\\\\\)/m';
$str = '\\\\ a multiline
comment \\\\
print (a)
\\\\inheritance and polymorphism\\\\;print ("ab");\\\\b\\\\;print("end")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);