package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[Mm][+-](\d*\.?\d+)$`)
var str = `m+1
m+.1
n+0.1
m+1.1
m-
M-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}