$re = '/^[Mm][+-](\d*\.?\d+)$/m';
$str = 'm+1
m+.1
n+0.1
m+1.1
m-
M-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);