package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$`)
var str = `Exemple@mail.com
exemple@mail.fr
exEmPle.exemple@mail.to
exemple.exemple.exemple@mail.org
EXEMPLE.exemple.EXEmple@mail.de
exemple+test@Màil.com
_exemple@Mail.com
_exemple.test@Mail-test.com
_exemple+test@mail-test-café.co.uk
exe_mple.test+tag@mail.com
exe_mple.test@mail.subdomain.com
exe_mple+test@mail.com
exemple@good2go.com
NotValid@mail.c
NotValid@mail
Not@.valid
@not.valid
@notvalid
notvalid@
notvalid.com
notvalid@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}