package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(GTX \d+)[\s\S]*`)
var str = `MSI GeForce GTX 1080 Ti DirectX 12 GeForce GTX 1080 Ti GAMING X 11G
asdff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}