re = /(GTX \d+)[\s\S]*/
str = 'MSI GeForce GTX 1080 Ti DirectX 12 GeForce GTX 1080 Ti GAMING X 11G
asdff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end