re = /^a\..*?\Kain't/mi
str = 'For instance, if in the text below I wanted to replace "ain\'t" with "is not" for lines beginning "a." but not "b.":
a. This ain\'t a worm.
b. No, it ain\'t.
a. Ain\'t a snake, either.
b. No, ain\'t one of them.
a. ain\'t multiple ain\'t and more ain\'t
'
subst = 'is not'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result